NetCut 2.14 obsolete?

This topic contains 7 replies, has 5 voices, and was last updated by  mist978 2 weeks, 4 days ago.

  • Author
    Posts
  • #3927

    fredrilf
    Participant

    I have been using netcut 2.14 for years and it has worked amazingly but recently the application will only run(and WORK) for a couple seconds until a message pops up telling me that the current version is obsolete and that I have to download a newer version. The newer version just doesnt seem to work however and the old version still works so why force us to download a newer and worse version of your program?

  • #3928

    admin
    Keymaster

    new version not working? is it not cut or not speed control?

  • #3957

    fredrilf
    Participant

    neither, I am unable to cut off users or control their speed. When I start the old version(2.1.4) it works until the program shuts itself off saying its obsolete. This program was working just fine until you started forcing people to use the newer version that shoves the premium offer on your face, id mutch rather pay to just keep the old version.

  • #3960

    admin
    Keymaster

    they should work same way. except 3.0 allow speed control at network support it. ie: most home wifi system.

    so you are seeing 3.x netcut not be able to cut off and 2.1.4 be able to at same network?

  • #3961

    sp4rta
    Participant

    same with me i’ve been use netcut 2.1.4 for years and now is obsolete? 2.1.4 version is much better than 3.0,, please don’t obsolete

  • #3963

    fredrilf
    Participant

    yes 2.1.4 works absolutely fine until it is forced off and 3.x will not work at all.

  • #3980

    Adham Hisham
    Participant

    Hmm
    Interesting

  • #5355

    mist978
    Participant

    I downloaded the latest netcut which is the browser version and it doesn’t work. It asks me to disable my adblock or buy the premium version. I have no adblock installed and i can actually see the ads so the problem is with the latest version itself. On the other hand Netcut 2.1.4 works great, but only for a few seconds until it asks me to update and says it is obsolete now. I don’t understand why you want us to force update when the updated version sucks.

You must be logged in to reply to this topic.